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Моделирование взрывного воздействия  
на конструкцию в LS-DYNA 

Смирнов А.А., МГТУ им. Н.Э. Баумана 
 

1. Введение 
При расчете отклика конструкции на взрывное воздействие с помощью 

программного комплекса LS-DYNA возможны два различных подхода для 
задания нагрузки. 

Первый связан с постановкой задачи детонации взрывчатого вещества 
(ВВ), распространения ударной волны в среде (обычно воздух) и взаимодей-
ствие ударной волны с элементами конструкции. Эта задача может быть ре-
шена в LS-DYNA с привлечением многокомпонентной гидродинамики (Mul-
timaterial Eulerian Hydrodynamics) и произвольных лагранжево-эйлеровых се-
ток (ALE – Arbitrary Lagrangian-Euleran) [1]. Этот подход хотя и является бо-
лее общим и, возможно, более точным для решения задач взрыва, однако он 
более трудоемок как в подготовке анализа, так и при расчете.  

Второй подход состоит в задании взрывного воздействия на элемент 
конструкции в виде функции давления от времени. При этом давление, дей-
ствующее на элемент, рассчитывается по эмпирическим зависимостям, полу-
ченным на основе обширного экспериментального материала. Для примене-
ния этого подхода в LS-DYNA реализована специальная функция CONWEP, 
позволяющая определить и задать давление, действующее на элемент, зная 
массу заряда (в ТНТ-эквиваленте), расстояние до него, а также ориентацию 
элемента в пространстве. Функция CONWEP вводится в расчетный k-файл с 
помощью ключевого слова *LOAD_BLAST. Применение данной функции 
позволяет моделировать взрывное воздействие на конструкцию с приемле-
мой точностью, не решая при этом трудоемкую задачу детонации ВВ, рас-
пространение ударной волны и ее взаимодействие с конструкцией.  Данный 
подход и рассмотрен более подробно ниже. 

 
2. Функция CONWEP 

 
Согласно разработчикам функции CONWEP [2], она представляет со-

бой реализацию эмпирической модели Кингери и Балмэша (Kingery and 
Bulmash) для воздушной ударной волны. Проведенные авторами сравнения 
результатов вычислительного эксперимента с экспериментальными данными 
показали адекватность разработанной функции при решении таких задач, как 
воздействие ударной волны от наземных мин на транспортные средства. 
Имеющиеся зарубежные публикации также показывают, что данная функция 
может успешно применяться при моделировании взрывного воздействия на 
здания и другие строительные конструкции. 

Ограничения в применении данной функции состоят в том, что она не 
учитывает эффекты "затенения" ударной волны объектами, лежащими на пу-
ти ее распространения, и локальные эффекты ее отражения от элементов 
конструкции.  
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Входными переменными для функции CONWEP являются следующие 
параметры: 

1) weight – масса заряда в ТНТ-эквиваленте; 
2) x0, y0, z0 – координаты расположения заряда в глобальной системе 

координат модели; 
3) t0 – время задержки между началом расчета и моментом начала де-

тонации заряда (может быть отрицательным); 
4) nunit - флаг единиц измерения. Возможны следующие значения: 

1 – фунты, футы, фунты на квадратный дюйм (psi), секунды; 
2 – килограммы, метры, Паскали, секунды; 
3 – десятки слагов1, дюймы, фунты на квадратный дюйм (psi), 
секунды; 
4 – граммы, сантиметры, мегабары, микросекунды; 
5 – единицы измерения, определяемые пользователем; 

5) isurf - флаг типа взрывной волны. Возможны следующие значения: 
1 – взрыв на поверхности; 
2 – взрыв в воздухе. 

Кроме этого функция CONWEP требует указания списка оболочечных 
(shell) элементов, на которые прикладывается взрывное воздействие. Если 
воздействие необходимо приложить к объемным (solid) элементам, то для 
функции необходимо задать список соответствующих сегментов. 

 
3. Подготовка расчетной модели 

 
Рассмотрим подготовку расчетной модели для моделирования взрыв-

ного воздействия на примере использования программного комплекса AN-
SYS в качестве препроцессора.  

Геометрическая модель, содержащая поверхности, создается в пакете 
3-х мерного моделирования (например, в SolidWorks) и сохраняется в ней-
тральном формате IGES, PARASOLID или другом. Перед сохранением необ-
ходимо правильно установить единицы измерения длины. Обычно это – мет-
ры, так как в ANSYS и LS-DYNA удобно использовать систему единиц СИ. 
Загрузив ANSYS, импортируем созданную модель с помощью команд 
File>Import>IGES…или File>Import>PARA… Интересно, что после ус-
пешного импорта объемы в ANSYS отображаются в виде набора линий. Что-
бы они отображались в привычном виде необходимо выполнить команду 
/facet, NORM. 

Далее построение расчетной модели мало чем отличается от обычной 
процедуры в ANSYS. Перечислим лишь основные этапы этого процесса, и 
остановимся кратко на некоторых особенностях, характерных именно для 
LS-DYNA. Для того чтобы появились некоторые пункты в меню, позволяю-
щие использовать препроцессор для подготовки анализа LS-DYNA, необхо-
димо выполнить команду Main Menu>Preferences… LS-DYNA Explicit. 

                                                 
1 Слаг (от англ. slug) – масса, которой сила в 1 фунт сообщает ускорение в 1 фут/с2; 1 слаг = 14,594 кг. 



 3

1. Задание типов элементов и параметров сечений. Для расчета в LS-
DYNA применимы типы элементов SHELL163 (для оболочечных элементов) 
и SOLID164 (для объемных элементов). 

2. Задание моделей материалов. Для металлических материалов, под-
вергающихся ударному нагружению в первом приближении можно восполь-
зоваться моделью материала с билинейным кинематическим упрочнением 
(соответствует  3-ей модели материала в LS-DYNA – 
*MAT_PLASTIC_KINEMATIC). Эта модель в простейшем случае описыва-
ется четырьмя параметрами: плотностью ρ , модулем упругости (Юнга) E , 
пределом текучести тσ  и касательным модулем упругости танE . Смысл этих 
параметров ясен из рис. 1, на котором представлена схематизированная диа-
грамма деформирования образца материала. Например, для стали Ст3 данная 
модель материала может быть задана с помощью следующих команд: 

mp, ex, 1, 2e11 ! модуль Юнга  
mp, dens, 1, 7800 ! плотность 
tb, bkin, 1 ! модель с билинейным упрочнением   
tbdat, 1, 252e6 ! предел текучести 
tbdat, 2, 104e7 ! касательный модуль упругости 
Для отечественных марок сталей и некоторых сплавов параметры E , 

тσ  и танE  можно найти в [3, 4, 5]. 
Кроме того, при расчетах час-

то требуется учесть разрушение ма-
териала при слишком больших де-
формациях. Как это сделать описано 
в разделе, посвященном корректи-
ровке k-файла.  

3. Разбиение на конечные эле-
менты. Перед тем, как приступить к 
разбиению поверхностей на элемен-
ты необходимо проверить ориента-
цию их нормалей по отношению к 
точке расположения заряда. Нормаль 
поверхности должна быть направле-
на в сторону заряда (рис. 2). Отобра-
зить нормали поверхностей можно с 
помощью команды: 
 PlotCtrl>Symbols>ADIR Area di-
rection>On.  

Изменить направление норма-
ли можно с помощью команды: 
Main Menu>Preprocessor> Model-
ing>Move/Modify>Reverse Normals 
> of Areas. 

После разбиение на элементы 

 
Рис. 2. Ориентация нормали поверхности 

 
Рис. 1. Схематизированная диаграмма 

деформирования 
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совпадающие узлы элементов, моделирующих одно тело, необходимо слить 
воедино. Это производится с помощью команды Main 
Menu>Preprocessor>Numbering Ctrls>Merge Items… Nodes. 

4. Создание Parts и компонентов. Для дальнейшего анализа в LS-DYNA 
необходимо создать так называемые Parts. Parts – это совокупность элемен-
тов, обладающих уникальной комбинацией типа элемента, модели материала 
и параметров сечения. Для автоматического создания Parts возможно исполь-
зование команды Main Menu>Preprocessor>LS-DYNA Options>Parts 
Options… Create all parts. Для удобства приложения взрывной нагрузки не-
обходимо создать компонент, содержащий элементы, подвергающиеся 
взрывному воздействию. Для этого необходимо сначала выбрать нужные 
элементы, затем, используя команду Select>Component Manager>Create 
Component>Elements, задать создаваемому компоненту имя, например, 
E_BLASTLOAD. 

5. Задание граничных условий и нагрузок. Кроме обычных граничных 
условий, задающих тип закрепления, условия симметрии и т.д., необходимо 
подготовить модель к заданию взрывного воздействия. Для этого следует за-
дать действие давления на элементы, объединенные в ранее созданном ком-

поненте E_BLASTLOAD. Осо-
бенностью LS-DYNA является то, 
что все нагрузки в ней задаются в 
виде кривых нагружения, завися-
щих от времени. 

Следует отметить, что для 
правильной работы функции 
CONWEP в k-файле должно быть 
определено как минимум две 
кривые нагружения. Одна кривая 
задается в препроцессоре ANSYS 
– она будет имитировать взрыв-
ное воздействие, вторая задается 
при корректировке k-файла (см. 
ниже) и является "фиктивной".  

Для того чтобы определить 
кривую в ANSYS необходимо за-
дать два массива параметров, на-
пример PLOAD и TIME с помо-
щью команды Parameters>Array 
Parameters>Define/ Edit…Add… 
Необходимо ввести хотя бы две 
точки в каждом массиве. 

Давление на элементы зада-
ется с помощью команды Main 

Menu>Solution>Loading 
Options>Specify Loads (рис. 3). 

 
 

Рис. 3. Диалоговое окно Specify Loads
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Необходимо указать: 
Load Labels: PRES; 
Component name or Part number: E_BLASTLOAD; 
Parameter name for time values: TIME 
Parameter name for data values: PLOAD. 

6. Задание контактных условий. В LS-DYNA имеется более десятка 
различных типов контактных условий, которые учитывают тип контакти-
рующих элементов, возможность разрушения (эрозии) элементов при кон-
такте и др. Но, пожалуй, одним из универсальных типов контакта является 
тип Automatic single surface contact (ASSC). При задании этого типа контакта 
нет необходимости указывать контактирующие поверхности  – они автома-
тически определяются в ходе расчета. Тип контакта и параметры трения в 
контакте задаются с помощью команды Main Menu>Preprocessor>LS-
DYNA Options>Contact>Define Contact. В появляющемся диалоговом окне 
можно задать: тип контакта (Contact Type), коэффициент трения покоя (Static 
Friction Coefficient, FS), коэффициент вязкого трения (Viscous  Friction Coef-
ficient, VC), коэффициент вязкого демпфирования в процентах от коэффици-
ента критического демпфирования (Viscous  Damping Coefficient, VDC).  

Коэффициент вязкого трения VC вводится для того, чтобы ограничить 
максимальную силу трения, возникающую в контакте. Рекомендуемое значе-
ние VC равно пределу текучести по касательным напряжениям, который мо-
жет быть оценен по формуле: 3тт στ = . 

Коэффициент VDC обычно принимается равным 10–20%. 
7. Задание параметров управления расчетом и типа выходных данных. 

В этой части подготовки анализа задается время расчета, интервал записи ре-
зультатов расчета во внешний файл, необходимые файлы с дополнительными 
выходными данными. Для этих действий используются команды из ветки 
меню Main Menu>Solution>Output Controls 

8. Генерация k-файла. По окончании этапа подготовки анализа необхо-
димо создать k-файл, который в дальнейшем будет корректироваться для мо-
делирования взрывной нагрузки: Main Menu>Solution>Write Jobname.k. 
При сохранении k-файла выдается запрос, в каком формате сохранять ре-
зультаты. Так как для анализа результатов в общем случае удобнее пользо-
ваться постпроцессором от LS-DYNA (файл lsprepostd.exe), то необходимо 
указать: Write results files for … LS-DYNA. 

 
4. Корректировка k-файла 

 
Созданный k-файл является обыкновенным текстовым файлом и может 

быть открыт и отредактирован в любом текстовом редакторе. В этом файле 
содержаться так называемые карты (cards), начинающиеся с того или иного 
ключевого слова (keyword). Ключевое слово всегда начинается со звездочки 
(*), и обычно записывается заглавными буквами. Если в k-файле не исполь-
зуются разделители в виде запятых (а ANSYS создает файл без разделите-
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лей), то числовые параметры, записываемые в картах, должны быть распо-
ложены в строго определенной позиции на строке. Это необходимо учиты-
вать при редактировании файла, иначе при запуске LS-DYNA будут выда-
ваться ошибки. Ключевые слова и формат соответствующих карт подробно 
описаны в [6]. Если строка начинается со знака $, то она воспринимается как 
коментарий. На рис. 4 проиллюстрирована взаимосвязь основных ключевых 
слов в k-файле. Каждая карта определяет в модели некоторый объект или 
объекты: узлы, элементы, детали, поперечные сечения, материалы, уравнения 
состояний и т.д. Определяемому объекту присваивается идентификатор ID, с 

помощью которого он мо-
жет быть однозначно 
идентифицирован в любом 
месте файла. Важно отме-
тить, что кривой нагруже-
ния, определяемой функ-
цией CONWEP соответст-
вует идентификатор –2. 

Итак, проведем кор-
ректировку k-файла в сле-
дующем порядке.  

1. Зададим дефор-
мационный критерий разрушения для материала, из которого состоят эле-
менты конструкции, подвергающиеся взрывному воздействию. Для этого в 
карте, начинающейся с ключевого слова *MAT_PLASTIC_KINEMATIC, из-
меним третий параметр во второй строке с 0.00 на 0.78 (для стали Ст3): 

 
*MAT_PLASTIC_KINEMATIC 
         1 0.783E+04 0.200E+12  0.300000 0.322E+09 0.340E+09  0.00     
  0.00      0.00      0.78   
 

2. Определим вторую кривую нагружения (фиктивную), которая необ-
ходима для корректной работы функции CONWEP. Если в файле уже при-
сутствуют две кривые, то этот этап можно пропустить. Находим в файле кар-
ту с ключевым словом *DEFINE_CURVE, копируем ее и изменяем у новой 
кривой идентификатор: 
 
*DEFINE_CURVE 
         1         0     1.000     1.000     0.000     0.000 
  0.000000000000E+00 -5.000000000000E+02 
  6.000000000000E-03 -5.000000000000E+02 
*DEFINE_CURVE 
         2         0     1.000     1.000     0.000     0.000 
  0.000000000000E+00 -5.000000000000E+02 
  6.000000000000E-03 -5.000000000000E+02   
   

3. Зададим взрывную нагрузку. Функция CONWEP определяется в k-
файле с помощью ключевого слова *LOAD_BLAST. Ниже приведен фраг-
мент, который необходимо вставить в файл, чтобы задать взрывное воздейст-
вие от заряда массой 6 кг в ТНТ-эквиваленте (wgt), расположенного  в точке 

 
Рис. 4. Взаимосвязь ключевых слов в  k-файле [6] 
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с координатами x=0 (xbo), y= –0,4 (ybo), z=3,2 (zbo) в глобальной системе ко-
ординат на поверхности (isurf). Время срабатывания заряда совпадает с на-
чалом расчета (tbo), числовые параметры заданы в единицах системы СИ 
(iunit): 

 
*LOAD_BLAST 
$     wgt       xbo       ybo       zbo       tbo     iunit     isurf 
  6.000000     0.000  -0.40000   3.20000      0.0         2         1 
$     cfm       cfl       cft       cfp 
     0.000     0.000     0.000     0.000 

 
Ранее в ANSYS было задано действие давления на элементы, которые 

подвергаются взрывному воздействию. В k-файле за это отвечает фрагмент 
следующего вида: 

  
*SET_SHELL 
         1 
        31        32        33        34        35        36        37        38 

………………………………………………………………………… 
      1425      1426      1427      1428      1429      1430 
*LOAD_SHELL_SET 
         1         1     1.000     0.000 
 

Здесь необходимо изменить второй параметр (ID кривой нагружения) 
на –2 в карте, начинающейся с ключевого слова *LOAD_SHELL_SET: 
 
*LOAD_SHELL_SET 
         1        -2     1.000     0.000 
 

Отметим, что цифра '2' должна находиться на той же позиции, где 
раньше находилась цифра '1'. 

После проведенной корректировки расчетная модель, заданная в k-
файле готова к расчету в LS-DYNA. 
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